Configuración puertos (SOLUCIONADO)

Responder
danitut
Mensajes: 9
Registrado: Mié Jul 24, 2019 6:54 am

Configuración puertos (SOLUCIONADO)

Mensaje por danitut » Mar Abr 21, 2020 1:29 pm

Hola, tengo problemas de configuración y estoy muy perdido.
Hace poco conseguí actualizar el server y el Mega a la V4 pero no consigo que funcione MQTT, el resto funciona perfectamente.
Cuando ejecuto el Server me dice esto:
15:14 > MQQTT SERVER RUNNING
15:14 > Error apertura puerto de escucha, ¿Desactivo el servicio?
15:14 > Error apertura puerto de escucha, ¿Desactivo el servicio?

Esta es la configuración que tengo en el archivo MQTT.XML
<?xml version="1.0" encoding="utf-16"?>
<Config ip="192.168.1.175" Port="1885" >

</Config>

El puerto lo tengo abierto en el Firewall del Server y no obstante he desactivado el Firewall.
No se porque si pongo el puerto 1884 me da error de carga del archivo MQTT.
Y otra cosa más, en el configurador, en la pestaña del server, activo el Local Server y le pongo la IP del server y el mismo puerto que en el archivo MQTT.XML.
Muchas gracias.
No tienes los permisos requeridos para ver los archivos adjuntos a este mensaje.
Última edición por danitut el Lun Abr 27, 2020 5:16 am, editado 2 veces en total.

Avatar de Usuario
Sigmundfreud
Mensajes: 399
Registrado: Mar Feb 12, 2019 8:23 pm
Ubicación: Girona

Re: CONFIGURACIÓN PUERTOS

Mensaje por Sigmundfreud » Mié Abr 22, 2020 6:41 am

En el configurador el puerto del server es 21099, que es el que el arduino usa para comunicarse con el server.

Una vez cambiado prueba a poner al mqtt 1884.


Cuando habras exserver previamente tienes que haber parado el servicio, ya que usan el mismo puerto y no puedem funionar loa dos a la vez. Una vez acabes con exserver vuelve a iniciar el servicio
Una persona que nunca se ha equivocado es porque nunca ha probado nada nuevo
(Albert Einstein)

En mi lista ya hay 5 mkr, 1shield excontrol, 1 extensión, 1 nano iot33, multiples CI...... :lol: :lol: :lol:

danitut
Mensajes: 9
Registrado: Mié Jul 24, 2019 6:54 am

Re: CONFIGURACIÓN PUERTOS

Mensaje por danitut » Mié Abr 22, 2020 3:48 pm

Buenas noticias, ya lo tengo funcionando.
Ahora toca pelearme con Node-red

Muchas gracias otra vez Sigmundfreud

Responder

Volver a “MQTT”

¿Quién está conectado?

Usuarios navegando por este Foro: No hay usuarios registrados visitando el Foro y 0 invitados